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textexpander

The Customizable Typing Shortcut Utility That Saves You Time!

TextExpander is a utility that helps you type more efficiently and accurately. TextExpander watches what you type
and inserts predefined snippets on the fly whenever you enter their corresponding abbreviations. Read what's new in
this version of TextExpander.

Insert standard greetings, text, and signatures — including formatted text and pictures
Save keystrokes by typing simple abbreviations to get long snippets

Correct typos automatically

Sync snippets via MobileMe and Dropbox

Organize snippets into groups

Add snippet groups from external files and online sources

HTML, CSS, Autocorrect, Accented Word, Symbol snippet groups included

Insert the current date and time in any format you prefer

Print snippets by group

Type special characters without launching the special characters palette

Position the cursor wherever you want in your expanded snippet

For programmers, make editor-independent code templates; invoke AppleScripts and shell scripts
Import from Typelt4Me (v2 & 3)

Available in English, German, French, Japanese and ltalian
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Designed for ease-of-use, TextExpander works seamlessly as you type.

System Requirements

Purchasing
Updates
Installing

Help
Uninstall

Disclaimer

System Requirements

Mac OS X 10.6 or above is required for TextExpander 3.x.
(TextExpander 2.8.1 is available for Mac OS X 10.4 - 10.5.x.)

Purchasing
TextExpander costs US $34.95, and may be purchased one of three ways.

o From the demo itself:

Choose Purchase / Register TextExpander... from the TextExpander menu and press Buy Now.
o From our online store:

Go to: http://store.esellerate.net/somm/textexpander

o On the Mac App Store

Updates

Find the latest version of TextExpander and technical support at: http://www.smilesoftware.com/textexpander/

How Do | Install TextExpander?
I. Unzip the downloaded .zip file.
2. Drag the TextExpander application to your Applications folder, or wherever you prefer to put your
applications.
3. Double-click the TextExpander application to launch.

Where Can | Get Help for TextExpander?

TextExpander ships with extensive online help. Select TextExpander Help from the Help menu of TextExpander to
view the help.

If you can't find an answer to your question in the TextExpander Help, please email our fast and friendly technical
support team at support@smilesoftware.com.

How Do | Uninstall TextExpander?
Drag the TextExpander application icon to the Trash.

For complete removal, also move to the Trash:
[home]/Library/Application Support/TextExpander (this is where your snippet data is stored)
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Disclaimer

This software is provided "as is" and any express or implied warranties, including, but not limited to, the implied
warranties of merchantibility and fitness for a particular purpose are disclaimed. In no event shall the copyright owner
or contributors be liable for any direct, indirect, incidental, special, exemplary, or consequential damages (including,
but not limited to, procurement of substitute goods or services; loss of use, data, or profits; or business interruption)
however caused and on any theory of liability, whether in contract, strict liability, or tort (including negligence or
otherwise) arising in any way out of the use of this software, even if advised of the possibility of such damage.

TextExpander is produced by:

SmileOnMyMac, LLC dba Smile
PMB 278

350 Bay Street, Suite 100,

San Francisco, CA 94133

We welcome your inquiries and feedback at: textexpander@smilesoftware.com

Acknowledgments

TextExpander includes libcurl http://curl.haxx.se/libcurl/,
which stipulates we include the following:

COPYRIGHT AND PERMISSION NOTICE

Copyright (c) 1996 - 2002, Daniel Stenberg, daniel@haxx.se.

All rights reserved.

Permission to use, copy, modify, and distribute this software for any
purpose with or without fee is hereby granted, provided that the above
copyright notice and this permission notice appear in all copies.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OF
THIRD PARTY RIGHTS. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS
BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN
ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
SOFTWARE.

Except as contained in this notice, the name of a copyright holder shall
not be used in advertising or otherwise to promote the sale, use or
other dealings in this Software without prior written authorization of
the copyright holder.

TextExpander includes portions Copyright (c) The Growl Project,
2004-2005 All rights reserved.

Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are
met:

1. Redistributions of source code must retain the above copyright
notice, this list of conditions and the following disclaimer. 2.
Redistributions in binary form must reproduce the above copyright
notice, this list of conditions and the following disclaimer in the
documentation and/or other materials provided with the distribution. 3.
Neither the name of Growl nor the names of its contributors may be used
to endorse or promote products derived from this software without
specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS
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IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED
TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER
OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
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Help: Guided Tour — Main Window
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a. Snippets and groups list

b. Add snippets and groups (see "Creating Snippets" and "Grouping Snippets and Importing Groups")
c. Tool menu (see "Sorting and Filtering" and "Duplicating, Saving and Printing Snippets")

d. Snippet format drop-down menu (see "Creating Snippets: Format")
e
f.

. Snippet content (see "Creating Snippets")
Insert built-in macros: date, time, clipboard, cursor position etc. (see "Creating Snippets: Adding
Macros to Snippets")

. Formatted text style options (see "Creating Snippets: Format")

. Snippet label (see "Creating Snippets: Labeling Snippets")

. Snippet abbreviation, case sensitivity setting (see "Creating Snippets: Setting Case Sensitivity")
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Help: Guided Tour: Menu Bar Item

The TextExpander icon appears in the menu bar by default. Clicking the icon provides a
convenient way to:

o Search Snippets
Type a few letters into the search field and all the matching snippets are presented.

Press return or tab to move focus to the list of results where up and down arrow keys
move the selection and return inserts the selected snippet, or click on a snippet to insert.

o Open TextExpander
Reveal TextExpander's main window.
(If you choose to hide TextExpander in the Dock (see Preferences: Appearance),
TextExpander's Main Window is also hidden.)

o Enable/Disable Expansion
Useful when you want to temporarily disable TextExpander so that you can type without
any expansions being triggered.

o Create New Snippet...
Opens the Create Snippet window. Enter the snippet content and abbreviation, choose a
shippet group to assign it to, and click Create.

o Create Snippet from Selection...
Opens the Create Snippet window with the currently selected text as the snippet content.
Create an abbreviation, choose a snippet group to assign it to, and click Create.

o Create Snippet from Clipboard...
Opens the Create Snippet window with the current content of the Clipboard as the
snippet content. Create an abbreviation, choose a snippet group to assign it to, and click
Create.

o Edit Last Expanded Snippet...
Opens the snippet you expanded last so that you can edit it. After you make the desired
changes, click Save.

o View all your snippets
All your snippet groups are accessible from the TextExpander menu bar item.

The appearance of the TextExpander icon varies to indicate expansion status. If expansion is
disabled, the icon changes to gray. If an application enables secure event input, which blocks
expansion, a red lock appears on top of the icon and the Enable/Disable Expansion menu item
shows which application enabled secure input. You can read more about secure event input and
TextExpander on this web page.

© 2006-201 1 SmileOnMyMac, LLC, dba Smile. All rights reserved.
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Help: Creating Snippets

Three Steps to Creating a Basic Snippet

I. Click on New Snippet (_‘3 in the toolbar or choose File > New Snippet from the menu.
2. Add the snippet content in to the "Content" box on the right.
3. Assign an abbreviation in the "Abbreviation" box below the content.

Note: You can also create new snippets from selected text or from the Clipboard contents. For
more details, see below.

If you have TextExpander hidden in the Dock (see Preferences: Appearance), you will need to
access the snippet creation menus via the TextExpander menu bar item or via predefined hotkey
shortcuts.

What Makes a Good Abbreviation
A good abbreviation is:

o short

o easy to remember

o unlikely to be typed by accident

o unique
Duplicating an abbreviation's first character (ddate, ssig, zzip) is one way of creating abbreviations
that meet these critieria.

If abbreviations conflict, they are highlighted in orange. Conflicting abbreviations cannot trigger
expansions.

Format
Snippet content has four format options:

o Plain Text
When expanded, the snippet content conforms to the current text style.
o Formatted Text, Pictures
Color, size, font and alignment can be specified for text. Images can be used.
o AppleScript (advanced)
The snippet content can be an AppleScript, which is triggered by the abbreviation.
o Shell Script (advanced)
The snippet content can be a shell script, which is triggered by the abbreviation.

To set content format, click on the drop down menu at the top of the Content box.

Using Formatted Text in Snippets
I. Set the content format to Formatted Text, Pictures.
2. Add snippet content in the Content box.
3. Select text to be formatted.
4. Click on the ‘ T~ ‘ button below the Content window to access Font and Text options for
fonts, size, color, and alignment.

Adding Images to Snippets
I. Set the content format to Formatted Text, Pictures.
2. Drag your image into the Content box or copy it to the Clipboard and use Command + V
to paste it into TextExpander.
3. To remove an image, use the Delete key.

A default content format is set in TextExpander > Preferences under the Expansion tab.
Adding Macros to Snippets

Insert predefined macros to snippets via the insert button ‘ Iv ‘ below the Content box.
Predefined macros include:
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o Date
Inserts the day, month and year of the current date in a variety of formats

o Time
Inserts the current time in hours, minutes, seconds and AM/PM.

o Date/Time Math
Inserts a date or time that takes the current date/time and adds to or subtracts from it;
e.g. five days from today.

o Snippet
Nest a snippet within your snippet. For example, you might want to use your telephone
number snippet in your email signature snippet. If your telephone number changes, you
need only update one snippet.

o Key (new!)
Inserts a key press for Enter, Esc, Return or Tab; useful for web forms.

o Fill-in (new!)
Inserts custom fields into your snippets that can be filled in while expanding the snippet;
useful for form letters, e.g. "Dear ____, Thank you for the ____."

o Clipboard
Inserts whatever is on the Clipboard into your snippet when expanded.

o Picture...
Browse for an image to insert. Images can also be dragged directly into the content box or
pasted from the Clipboard.

o Cursor
Specify where you want the cursor to appear after the snippet is expanded. TextExpander
repositions the cursor automatically.

Labeling Snippets

By default, a snippet's label is a shortened version of the snippet contents. You can specify a short,
more useful label to appear in the snippet list instead. Enter the label in the Label field below the
Content Box.

Setting Case Sensitivity
TextExpander abbreviations can be case sensitive. There are three options:

o Case Sensitive (aB, Ab, ab, AB differ)

Example: "YT" expands to "Yours Truly", "yt" does not.
o Ignore Case (aB, Ab, ab, AB same)

Example: either "YT" or "yt" expands to "Yours Truly"
o Adapt Snippet to Case of Abbreviation

Example: "Yt" expands to "Yours truly", "yt" expands to "yours truly"

A default case sensitivity is set in TextExpander > Preferences under the Expansion tab. (See
Preferences.) You can change the case sensitivity setting on individual snippets by clicking the
drop-down menu bar above the Abbreviation box.

Create Snippet from Selection or Clipboard

A quick way to add snippets to your collection is to create new snippets based on a text selection
or on the Clipboard contents. If you've just typed something and realize that it would be a useful
snippet for future use, follow these steps:

I. Select the text you want for the snippet content.

2. Click the TextExpander menu bar item

3. Click Create Snippet from Selection... (or Create Snippet from Clipboard... if you have
copied the text to the Clipboard.)

The Create Snippet window opens with your selection (or the Clipboard contents) already
entered in the Content field. Assign an abbreviation and a snippet group and click Create.

You can also access Create Snippet from Selection or Create Snippet from Clipboard via hotkey.

Edit last expanded snippet (new!)

You can easily edit snippets as you are using them. If you expand a snippet and realize that it needs
to be revised (e.g. new phone number in your signature, new product name in your boilerplate),
try this:

I. Click the TextExpander menu bar item

2. Click Edit Last Expanded Snippet.

3. Make your revisions in the Edit Snippet window and click Save.



You can also access Edit Last Expanded Snippet via hotkey.

Deleting a Snippet
I. Select the snippet in the Snippet list on the left side of the TextExpander main window.

2. Click on Delete w in the toolbar, or use the Delete key on your keyboard.

© 2006-201 1 SmileOnMyMac, LLC, dba Smile. All rights reserved.
SmileOnMyMac and TextExpander are trademarks of SmileOnMyMac, LLC, dba Smile.
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Help: Expanding Snippets

Expand immediately vs. using delimiters

Under TextExpander > Preferences > Expansion, you can set when TextExpander expands a
snippet.

TextExpander can expand your snippets immediately when you type the abbreviations. Many users
prefer this mode because it feels faster and more seamless. However, you need to choose
abbreviations that would not appear in your normal typing. For example, "sig" is a poor
abbreviation when using "Expand immediately”, because your snippet will be expanded every time
you want to type the word "sign" or "signal".

If you use delimiters, you have more flexibility with abbreviations. No expansion occurs until you
press a delimiter key, indicating that you want the abbreviation to be expanded. For example, you
could use "sig" to enter your signature if you were using delimiters. Your signature snippet would
not be expanded until you pressed a specified delimiter after typing "sig".

By default, space, tab, return and esc keys are designated delimiters, but you can use any of a large
group of characters as additional delimiters. Go to TextExpander > Preferences > Expansion and
click on the Set Delimiters... to see all the choices.

Suggest matching abbreviations

If you have a large snippet library, or you have trouble remembering your abbreviations, you will
find the abbreviation matching suggestions useful. To invoke this feature, you need to set a hotkey.

I. Go to TextExpander > Preferences > Hotkeys.

2. Click Push to set Hotkey next to Suggest Matching Abbreviations.

3. Press a key combination that includes Command, Control, Option and/or Shift plus any
letter or number to set your hotkey; e.g. Control + s.

When you want matching abbreviations to be suggested, type a few letters of the abbreviation or
of the snippet, and then press your assigned hotkey combination. Matching abbreviations are then
displayed in a scrolling window. Typing more letters will narrow the search. Use the arrow keys to
move up and down the list of results, and press Return when the desired snippet is selected to
expand it. You can also click on the desired snippet to expand it.

Search Snippets

Another way to find snippets is to use Search Snippets. You can open the Search Snippets window
by clicking on the TextExpander icon in the menu and then clicking Search Snippets. You can also
set a hotkey for Search Snippets in TextExpander > Preferences > Hotkeys. (Note that the hotkey
will work even if you do not have the TextExpander icon displayed in the menu bar.)

Type a few letters of the snippet's contents or of its abbreviation into the search field. The search
results are updated as you type.

Click on a snippet to expand it, or press return or tab to move the focus to the list of search
results. You can use the arrow keys to move up and down in the list, and press return to expand
the selected snippet.

Enable/Disable TextExpander

Occasionally, you might want to disable TextExpander temporarily, when you don't want your
snippet expansions to occur. You can do this by clicking on the TextExpander icon in the menu
and then clicking Disable Expansion. To enable TextExpander again, click again on the
TextExpander menu bar icon and then click Enable Expansion.

You can also accomplish this easily by assigning a hotkey for Enable/Disable TextExpander-.

I. Go to TextExpander > Preferences > Hotkeys.

2. Click Push to set Hotkey next to Enable/Disable TextExpander.

3. Press a key combination that includes Command, Control, Option and/or Shift plus any
letter or number to set your hotkey; e.g. Control + d.
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TextExpander will remember your assigned hotkey combination. You can use it to toggle
TextExpander on and off.

© 2006-201 1 SmileOnMyMac, LLC, dba Smile. All rights reserved.
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Help: Grouping Snippets and Importing Groups

TextExpander lets you organize your snippets into groups, as well as import snippet groups from
files and the web. Preferences can be set by group, including application exclusion, expansion
behavior and sounds. (See "Group Settings" below.)

When you first launch TextExpander, all your snippets are in one group called "TextExpander
Snippets.”

Creating A New Group

To create a new group, click on New Group |3 or choose File > New Group from the menu.

You can add snippets to the group by clicking on New Snippet C\_‘:} in the toolbar or choose File
> New Snippet from the menu. You can also drag snippets from other groups into the new
group's folder. (For more about snippet creation, see "Creating Snippets")

Add Group from File
You can add a group from an existing file of snippets.
I. Choose File > Add Group from File... from the menu.
2. Find the snippet file that you want to import as a snippet group.
3. Click Open.
The allowable snippet file formats are:
o TextExpander
o Typelt4Me (v2 and v3)
o Text files (comma- and tab-separated)
o RTF files (comma- and tab-separated)

o RTFD files (comma- and tab-separated)

Add Group from URL
You can add a group from a file of snippets hosted on the internet.
|. Choose File > Add Group from URL... from the menu.

2. Enter the URL of the snippet group you want to import from the web, e.g.
http://www.smilesoftware.com/te/example.textexpander.

3. Click OK.

The allowable snippet file formats are the same as listed above.

Add Predefined Group
SmileOnMyMac offers several snippet groups that you can link to:

o Accented Words
Over 50 English words of non-English origin that are spelled using diacritical accent marks.

o AutoCorrect Snippets
Over 100 of the most commonly-misspelled words in English.

o CSS Snippets
CSS selectors and declarations.

o HTML Snippets
HTML tags and special character codes.

o Internet Productivity Snippets
Shorten URLs automatically using services like bit.ly; validate URLs.

o Symbol Snippets
Insert common symbols, such as ®, ©, and €.
o TidBITS AutoCorrect Dictionary
2400+ English-language misspellings based on the exhaustive AutoCorrect Dictionary

created by TidBITS publisher Adam Engst and collaborator Micah Alpern. (For more
details, go to http://db.tidbits.com/article/6103.)
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Note: For best results when using AutoCorrect files, TextExpander should be set to expand
"immediately when typed" instead of "at delimiter". See Preferences: Expand Abbreviations for
more details.

Group Settings

To access a group's settings, select the group in the list on the left. The following preferences
appear on the right:

o Name
You can rename the group here.

o Location
This indicates where the group's snippet file is located, whether "Local" (within your
TextExpander preferences), "External File" (elsewhere on your hard drive) or "URL"
(online).

o Expand in
You can disable TextExpander to prevent it from working in specific applications. The
default is set in TextExpander > Preferences under the Expansion tab, but you can
customize which applications work with specific TextExpander groups. The options are:
o All Applications
Enables a group to work with all applications. This overrides any exclusions set in
the Preferences Pane.
o All Applications, Except...
Excludes certain applications from working with this group's snippets.
o Only These Applications...
Specifies which applications will work with this group's snippets.
o No Applications (Disable)
This group's snippets will not work in any application.

o Sound
Choose the sound that is played when a snippet is expanded, or choose "none".

o Expand After
Expansion options are set on a per-group basis. They determine whether an abbreviation
is expanded or not, depending on what precedes the abbreviation.
o Whitespace
The abbreviations are expanded only when preceded by a space. This is the
default option.
o All but letters and numbers
The abbreviations are expanded when preceded by any character, excluding
letters and numbers.
o All characters
The abbreviations are expanded wherever they are typed, even in the middle of a
word. Use this option cautiously.

o Include when suggesting abbreviations
Uncheck this box if you do not want the abbreviations in this snippet group to be included
when you ask TextExpander to provide suggestions.
See Using TextExpander: Suggest Matching Abbreviations for more information about
using this feature.

o Update
(for URL-based groups only)
TextExpander can check whether a URL group's source file has been updated. You can set
the frequency to Never, Daily, Weekly or Monthly.

© 2006-201 | SmileOnMyMac, LLC, dba Smile. All rights reserved.
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Help: Auto-correction
Add common typos to your snippet library

If you find yourself consistently misspelling certain words, you can add them to your TextExpander
snippet library to be corrected automatically.

Example: If you always type "recieve" instead of "receive”, create a new snippet with "receive" as
the content and "recieve" as the abbreviation. When you type the misspelled word, TextExpander
replaces it with the word spelled correctly.

Note: For best results when using auto-correction, TextExpander should be set to expand
"immediately when typed" instead of "at delimiter". For more details, see "Expanding snippets:
Expand immediately vs. use delimiter".

Use a predefined auto-correction snippet group

TextExpander offers two predefined auto-correction groups for commonly-misspelled words in
English. To add these groups to your snippet library, choose File > Add Predefined Group >
AutoCorrect Snippets to add 100 commonly-misspelled English words, or choose the TidBITs
AutoCorrect Dictionary with over 2000 entries in English for industrial strength auto-correction.

Capitalize new sentences

TextExpander can automatically correct the capitalization of the first letter in a sentence. Choose
TextExpander > Preferences > Options to enable this feature. The first letter after a period and a
space will be capitalized automatically.

Eliminate double capitals at sentence start

TextExpander can automatically correct the double capitals at the beginning of a sentence. Choose
TextExpander > Preferences > Options to enable this feature. If two capital letters are typed after
a period and a space, the second letter will be converted to lower case automatically.

© 2006-201 1 SmileOnMyMac, LLC, dba Smile. All rights reserved.
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Help: Sorting and Filtering

Sorting

TextExpander can sort your snippet library in a variety of ways. The sorting options are under
View in the menu, or accessed via the tool menu action icon | %~ | (located beneath the snippet
list). V

o Sort by content

o Sort by abbreviation

o Sort by date created

o Sort by date modified

o Sort by most recently used
o Sort by label

Filtering

You can also find snippets easily using the Filter box in the toolbar. Just type in a few letters
contained in the snippet or abbreviation you are looking for. Only groups and snippets containing
those letters are shown. To see all groups and snippets again you must clear the filter.

© 2006-201 1 SmileOnMyMac, LLC, dba Smile. All rights reserved.
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Help: AppleScript Snippets and Shell Script Snippets
AppleScript Snippets

In the content format drop-down menu, choose "AppleScript” as the format type. In the content
field, enter an AppleScript such as this one:

- Adjust greetingsList values to your preferred greeting

set greetingsList to {"Sincerely", "Yours Truly", "Peace Out", "Have a good day",
"kthxbai"}

set listLength to count greetingsList

set randomNumber to (random number from | to listLength)

set selectedGreeting to item randomNumber of greetingsList

return selectedGreeting

Shell Script Snippets

In the content format drop-down menu, choose "Shell Script" as the format type. In the content
field, enter a shell script such as this one:

#1/usr/bin/perl
print "Hello from Perl!\n";

Your shell script must have the “shebang” (#!) on its first line and that must specify the interpreter
to be used for your script.

Here is an example of a Unix shell script

#!1/bin/bash
echo "Hello from Bash!"

Nesting Script Snippets

AppleScript snippets and shell script snippets can be nested within text snippets using the nested
snippet macro %snippet:[snippet name]%.

Example: if the AppleScript snippet above had the abbreviation "eend", you could use it in a text
shippet:

Dear Reader,

Thank you for your feedback on my book.

%snippet:eend%,

- Author
which would expand to:

Dear Reader,

Thank you for your feedback on my book.
Have a good day,

- Author

or one of the other random choices in greetingsList.

Feel free to share your cool scripts with us.
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Help: Duplicating, Saving and Printing Snippets

Duplicate a Snippet
I. Select the snippet you want to duplicate.
2. Choose File > Duplicate from the menu.

The original and the duplicate will have the same abbreviation, so you'll need to change the
abbreviation on one to something unique.

Duplicate a Group
|. Select the group you want to duplicate.
2. Choose File > Duplicate from the menu.

Snippet groups from external files and from URLs cannot be edited. If you want an editable version,
duplicate the group and then delete the original URL- or file-based group. The duplicate group will
not be updated from its original source.

Save a Copy of a Group
It's always a good idea to back up your snippets.

|. Select the group you want to save.
2. Choose File > Save a copy of group <group name>... from the menu.
3. Choose a location on your hard drive and click Save.

To restore a group that you have saved, choose File > Add Group from File...

Printing Snippets

As your snippet groups grow, it can be helpful to print out a list of abbreviations and snippets.
Print a Single Group

|. Select the group you want to print.
2. Choose File > Print group <group name>... from the menu.

Print All Groups

I. Choose File > Print all groups... from the menu.
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Help: Backup and Restore
Backing Up Settings and Snippets

TextExpander stores your settings (including your snippets) in a file on your Mac and updates that
file as you make changes.

By default, TextExpander creates a single backup file each time that it starts up.

In addition to the default backup, TextExpander has two other backup options that create
additional back up files:

o Atany time, you can manually create a backup file of your current settings and snippets by

clicking on Backup Now @ in the toolbar or choosing File > Backup TextExpander

Data from the menu.
o TextExpander can also automatically create backup files periodically (see Preferences:

Backup).
All backup files are stored in the Backup folder specified in Backup Preferences.
Restoring Settings

If you have accidentally deleted some snippets, or for some other reason want to return to an

earlier version of your settings, click on Restore in the toolbar or select File > Restore

Data from Backup. The window that appears lists the date and number of snippets of each of the
backup files in the Backup folder.

When you select a backup file and click Restore Backup, TextExpander will first create a new
backup file of your current settings (if you have any changes that are not backed up), then restore
the settings to those from the selected file.

Click Select Backup File... to restore from a backup file in some other location.

Another way to restore deleted snippets is to choose File > Add Group from File... to import all
the snippets from a backup file (see Grouping Snippets and Importing Groups).
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Help: Transitioning to TextExpander 3

Welcome to TextExpander 3! We've put a lot of effort into improving TextExpander. This page
explains some differences you may notice as a veteran TextExpander user.

What's different from TextExpander 2.x?

o TextExpander is now an application. It will prompt you to remove the TextExpander
system preferences pane. You may also choose Remove Older TextExpander from the
TextExpander menu.

o Access preferences using the Preferences... item of the TextExpander menu.

o Disabling expansion does not cause the TextExpander icon to disappear from the menu
bar. You can choose whether or not TextExpander appears in the menu bar under
Appearance in Preferences.

o If you use MobileMe or Dropbox for synchronization, please go to Sync in Preferences.
preferences and choose the matching option. We removed the per-group MobileMe
setting.

o In many cases, TextExpander can avoid using the clipboard entirely when expanding your
snippet. If you'd prefer TextExpander always use the clipboard, check Always use clipboard
to insert snippet under Expansion in Preferences.

o TextExpander 2.8 started including HTML as a data type when expanding snippets. This
allows you to include images in a Gmail signature. Some applications, notably Mail, do not
always respect font size settings for HTML data. You can now turn this behavior off by
unchecking Include HTML data under Expansion in Preferences.

o Complete list of what's new in TextExpander 3

Benefits of TextExpander 3 being an application:
o Interface modernization
o Horizontal window resizing
o Improved preferences interface
o Toolbar
o Searchable help in menu bar
o Double-click import of .textexpander files
o Greater long-term flexibility
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Help: How Much Time Has TextExpander Saved Me?
Click on Statistics M in the toolbar to find out!

SO0 Statistics

TextExpander saves you time and effort:

Snippets expanded: 17,491
Characters saved: 386,311
Hours saved: 18.40 at 70 ™! WPM
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