PDFpenPro logo PDFpenPro logo

Help: Extracting Pages

Extract a Page

  1. Show Thumbnail view in the Sidebar by clicking on the Sidebar buttonsidebar button in the toolbar and selecting Thumbnails from the menu (View > Thumbnails).
  2. Find the thumbnail of the page you want to extract and click on the thumbnail to select.
  3. Choose File > New > "From Selection"

A new document with your selected page will create.

Extract Multiple Pages

Select multiple pages to extract and create a new document, or add to another open document.

  • To select a range of thumbnails, select one thumbnail, then Shift-click on the thumbnail at the end of the range of pages you want to move.
  • To select multiple thumbnails that are not in a sequential range, Command-click on the thumbnails you want to move.
  • To select all the thumbnails in a PDF, select one thumbnail and choose Edit > "Select All" from the menu (Command+A).

Once multiple pages are selected, either choose File > New > "From Selection" to create a new document with the selected pages, or drag the selected pages from the Sidebar of the original document into the Sidebar of another document.

Tips on Extracting Pages

  • Selected pages in the original document will not automatically delete when extracted. If you no longer want the pages in the original document, select the pages in the Sidebar and tap delete on the keyboard to delete them from the document.
  • To expand the Sidebar view, hover over the divider between the Sidebar and main view until you see a double arrow. Drag the divider to the right to see all the pages.
  • To split a PDF document into individual PDFs, locate the AppleScript icon applescript and choose Script > "Split PDF."


© 2003-2019 SmileOnMyMac, LLC dba Smile. All rights reserved.
PDFpen and PDFpenPro are registered trademarks of Smile. The Smile logo is a trademark of Smile.