PDFpenPro logo PDFpenPro logo

Help: Working With Text

Selecting Text

Selected text can be copied and pasted into other applications. Text attributes (formatting, font, columns) are copied along with the text and match the original formatting as much as possible. Text is automatically selected in columns if your document is formatted that way.

  1. Make sure the Select Text tool select tool is active.
  2. Click and drag your mouse over the text you want to select.

Note: A PDF document that is a scan of a printed page is a bitmap image of text and will not have selectable text. It is treated as an image of text and not actual text.

When you try to select text in such a document it will ask to perform optical character recognition first. For details on generating selectable text from a scan, see "Using OCR (Optical Character Recognition)."

Tips on Selecting Text

  • Double-click to select a word; triple-click to select a whole line.
  • Select text across more than one page by changing pages and shift-clicking into the new page to extend the selection.
  • Select all the text in a document by choosing Edit > Select All (Cmd+A).

Correcting Text

PDFpenPro lets you edit or delete original text in your PDF document.

  1. Select the text you want to correct using the Select Text tool select tool.
  2. Click the Correct Text button correct text in the toolbar.
  3. The selected text is replaced with a text box that can be edited or deleted, just like any other text box.

Tips on Correcting Text

  • Correct Text works best on small portions of text in the same line or paragraph.
  • The results may not match the underlying text exactly. In particular, fonts and spacing will vary at times. PDFpenPro will match the font in the document with a font in your macOS provided Font Book. If you do not have the same font, it chooses the closest match.

Adding Text

Inserting a Text Box

  1. Select the Text tool text tool in the toolbar.
  2. Insert a text box in one of two ways:
    • Click anywhere on the page to insert a text box. The box will expand to hold the text you add.
    • Click and drag to create a text box with a specific size. The text will automatically wrap to the size of the box.
  3. Start typing. You can also paste text from the Clipboard that you've previously copied.
  4. Use the handles to resize the text box; the text will automatically wrap.

Tips for Adding Text

  • By default, the Text tool reverts to the Edit tool after inserting text. Double-click the Text tool to keep it selected. This is especially helpful when Filling Out Forms.
  • Option-dragging a text box with the Edit tool will make a copy of the box. This can save time if you are repeating a style.
  • Choose Edit > Wrap Text to change the wrapping mode on any text box.
  • Choose Arrange > Snap to Guides to snap into position a text box on the same baseline as existing text. (See Snap to Guides).

Special Characters

  • Superscript and Subscript are located in Format > Font > Baseline.
  • Other Characters are located in Edit > Emoji & Symbols. (Also through the Fonts window > Tools menu > Characters.)

Formatting Text

Changing Typeface or Text Size

  1. Select specific text you want to format or use the Edit tool to click on a text box and select the whole thing.
  2. Choose Format > Font > Show Fonts from the menu (Cmd+T).
  3. The system Font panel appears. Make the desired changes in the panel.

Changing Text Color

  1. Select specific text you want to format or use the Edit tool to click on a text box and select the whole thing.
  2. Go to the editing bar and locate the Object Properties menu. If the editing bar is not visible, go to View > Show Editing Bar (Cmd+Shft+E).
  3. Click on the Object Color item object color item. From the drop down menu choose one of the designated colors, or choose Other Text Color… to pick a custom color.

Changing Text Justification

  1. Click on a text box to select it.
  2. Choose Format > Text and then choose the alignment: Align Left, Center, Justify, Align Right.

Changing Line Spacing

  • Choose Format > Font > Baseline and select either Default, Raise or Lower.

Tip: Frequently-used text, including formatting, can be saved to the Library for reuse. (See Library).

Markup: Highlighting, Underscore, Strikethrough and Squiggle

PDFpenPro offers several ways to markup text by adding highlight colors, underscoring, strikethrough, and squiggle. The options are available by clicking and holding down on the Highlight button in the toolbar highlight button; by choosing Format > Highlight, where the shortcuts are listed; or by using the context sensitive menu made visible by right-clicking.

The markup will attempt to follow the line of the text exactly. If the text is not selectable text, or the highlight is not used on text, the highlight will follow the path of the cursor. Text can be made selectable using OCR.

Change the color of a Strikethrough, Underline or Squiggle

  1. Select the Highlight tool (Cmd+3) tool to add a strikethrough, underline, or squiggle.
  2. Select a color using Object Color object color item in the Object Properties palette.

The chosen color will remain the default color for that tool unless changed.

There are several means of performing markups:

Markup selected text

  1. Select some text.
  2. Hold the mouse down on the small arrow on the Highlight button highlight button to view the markup choices, then pick one.
    • Alternately, right-click or Control-click on the selected text. A context menu will appear with options for applying a highlight color, underscore, strikethrough, or squiggle. Click on an option.
  3. A highlight color, underscore, strikethrough, or squiggle will appear over the selected text.

Use the Highlight Text Tool

  1. Access the highlight tool in one of three ways:
    • Choose Tools > Highlight Text Tool (Cmd+3).
    • Click the Highlight Text Tool highlight tool in the editing bar.
    • Click the Highlight button in the toolbar highlight button. Click and hold the button for color and markup options.
  2. Drag over some text. The current highlight choice in the toolbar‘s Highlight button is used to markup the text. Choose a different markup from the Highlight button, and the Highlight Text tool becomes active.

Add a Note to a Highlight

  1. Double click on a highlighted section of text. You will see the text window of a Note appear.
  2. Type into the text window. When you are done the Note icon will appear next to the highlighted text. Optionally close the text window by clicking the red button in the upper left, or pressing the Escape key.
    For more on adding Notes, see Notes, Comments and Links.

Delete a Highlight

  1. Select the already highlighted text.
  2. Click on the Highlight button in the toolbar and click Remove. This will remove all highlights from the selected text. Alternately, access the Remove function by choosing Format > Highlight > Remove (Cmd+Shft+Opt+0).

Creating Custom Highlight Colors

You can create 3 custom highlight colors in the application Preferences.

  1. Go to the PDFpenPro menu > Preferences > Editing (Cmd+comma).
  2. Click on the color box custom highlight at the bottom of the Editing Preferences window.
  3. The macOS System Colors window opens; select a color.

Redacting Text

You can block out text (black out), or erase it (white out) with the redact function.

  1. Select the text you wish to redact.
  2. In the menu, choose Format > Redact text.

    • Choose Redact Text – Block if you want that text blacked out.
    • Choose Redact Text – Erase if you want a blank space in place of the text.

You will not be able to redact text that has already been made editable using the Correct Text button correct text. That text can instead be deleted.

Redact an Area

Redact a rectangular area of your document.

  1. Choose Tools > Select Rectangle tool (Cmd+4). Drag a rectangle over an area of your page.
  2. Choose Format > Redact Text - Block, or Erase. All of the content in the rectangle area is securely redacted.





© 2003-2017 SmileOnMyMac, LLC dba Smile. All rights reserved.
PDFpen and PDFpenPro are registered trademarks of Smile. The Smile logo is a trademark of Smile.